manual transmission woes

kemp

New Member
Messages
3
Likes
0
City
Badin
State
NC
Country
United States
What I Drive
2005 focus zx4 5 spd
#1
Was at gas station when this happened. Went to pull into the pump and heard noise/pop/grind when let out on pedal. Now I have no gears. but when car is in gear the speedometer registers like im moving. Each gear registers on speedo. 5th is fastest. At idle in 5th gear, when I let out on pedal it shows like im going 30 mph. any ideas?
I was hoping it was only clutch/pressure plate but now not sure.
Im starting to think I may need whole new transmission but not sure. Anyone had anything like this happen and what was the outcome?

Also, what is the newest year transmission that will fit in 05 zx4, 5 spd, 2.0 l ?
 
Last edited:
OP
K

kemp

New Member
Messages
3
Likes
0
City
Badin
State
NC
Country
United States
What I Drive
2005 focus zx4 5 spd
Thread Starter #3

Tom

Member
Staff Team
Messages
434
Likes
5
City
Sacramento
State
CA
Country
United States
What I Drive
'05 Saleen Focus, '17 Focus RS
#4
Similar thing happened to me at the race track. Car refuses to go into first gear but went into second and I was able to limp it home. Turns out it was a bad clutch.
 
OP
K

kemp

New Member
Messages
3
Likes
0
City
Badin
State
NC
Country
United States
What I Drive
2005 focus zx4 5 spd
Thread Starter #5
Similar thing happened to me at the race track. Car refuses to go into first gear but went into second and I was able to limp it home. Turns out it was a bad clutch.
Will be starting to work on it over next week or so. will keep yall informed. i sure hope thats all it is. thanks
 

Tom

Member
Staff Team
Messages
434
Likes
5
City
Sacramento
State
CA
Country
United States
What I Drive
'05 Saleen Focus, '17 Focus RS
#6
BTW how many miles on the transmission?
 

Similar threads



Top